В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mаster001
Mаster001
23.03.2022 13:34 •  Информатика

Free pascal. написать программу детектирования слова-полиндрома

Ответ:
petechkaPetrovPetor
petechkaPetrovPetor
06.10.2020 14:35
Var
    s: string;
    i: integer;

begin
    writeln('Введите строку:');
    readln(s);
    
    for i := 1 to length(s) div 2 do
        if s[i] <> s[length(s) - i + 1] then begin
            writeln('не палиндром');
            Halt;
        end;
    
    writeln('палиндром');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?