В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу, которая будет вводить пять целых чисел с клавиатуры и выводить на экран только те, которые принадлежат интервалам (0,5) и (-1,-8), либо выводить соответствующее сообщение.

Ответ:
gavronovaanna2oz9c0h
gavronovaanna2oz9c0h
06.10.2020 12:32
Если требуется выводить соответствующее сообщение в случае, когда таких чисел нет:
var i, x, k : integer;
Begin
 k:=0;
 for i:=1 to 5 do begin
 readln(x);
 if ((x>0) and (x<5)) or ((x>-8) and (x<-1)) then begin
   k:=k+1;
   writeln(x);
 end;
 end;
 if k=0 then writeln('нет таких чисел');
End.

Если требуется выводить соответствующее сообщение каждый раз когда число не входит в промежуток:
var i, x : integer;
Begin
 for i:=1 to 5 do begin
 readln(x);
 if ((x>0) and (x<5)) or ((x>-8) and (x<-1)) then
   writeln(x)
 else writeln(x,' не входит в промежуток');
 end;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?