Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
saraikinacaterina
21.01.2023 12:09 •
Информатика
Из массива х(n), n< =20, по невозрастанию значений эле- ментов, переписать в массив y без повторов значения элементов с четными индексами, меньшие c, сохранив программа на с++
Ответ:
Turbik327
06.10.2020 13:45
Int main()
{
int
*array_X,
*array_Y,
numOfEl,
border_C,
prevNum;
cout << "Input N: ";
cin >> numOfEl;
array_X = new int[numOfEl];
array_Y = new int[numOfEl / 2];
cout << "Input C: ";
cin >> border_C;
for (int i = 0; i < numOfEl; i++)
cin >> array_X[i];
prevNum = border_C;
for (int i = 0, j = 0; i < numOfEl; i += 2)
if (array_X[i] < border_C && array_X[i] != prevNum)
array_Y[j++] = prevNum = array_X[i];
cout << endl;
for (int i = 0; i < numOfEl; i++)
cout << array_X[i] << "; ";
cout << endl;
for (int i = 0; i < numOfEl / 2; i++)
cout << array_Y[i] << "; ";
system("pause");
return 0;
} /* End of the 'main' function */
0,0
(0 оценок)
Популярные вопросы: Информатика
John009
01.02.2020 10:28
Исследователь наблюдает изменение параметра, который может принимать одно из семи значений. значения записываются при количества бит. исследователь зафиксировал 120 значений....
viktoska87
27.06.2021 16:43
Составить блок схему алгоритма определения произведения n произвольных чисел...
Васелёк05
27.06.2021 16:43
Напишите программу на шая.вычеслите объем шара заданного радиуса.(v=4/3nr^3) n-число пи на паскале...
shakurovagaliya
27.06.2021 16:43
Задумайте 3 разных, произвольных чисел. -прибавьте к ним 25. -к ответу прибавьте ещё 125. -из ответа вычтите 36 -из ответа вычтите эти задуманные числа. -ответ умножьте на...
fogeimof
23.03.2023 05:56
До 21:00 как можно быстрее только 2 выполнить...
8orzakt
06.06.2020 16:42
Цикл n раз Робот выполнил программу, записанную ниже, и оказался в клетке f2. Цикл n раз Робот выполнил программу, записанную ниже, и оказался в клетке f2. нц 3 раз вправо...
andreyusachevp0cxzy
21.08.2020 00:19
ЗАДАЧА В ПАСКАЛЕ. ЗА СПАМ И Т.Д - ЖАЛОБА!...
0KULLEP0
25.05.2023 16:46
Назовите все числа которые делятся на 12...
zhenya270346
25.05.2023 16:46
Какие признаки волшебной сказке присутствуют в сказка о царе салтане ?...
Anastasia987654321
25.05.2023 16:46
За какое время камень, без начальной скорости, пройдет путь 80 м?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
{
int
*array_X,
*array_Y,
numOfEl,
border_C,
prevNum;
cout << "Input N: ";
cin >> numOfEl;
array_X = new int[numOfEl];
array_Y = new int[numOfEl / 2];
cout << "Input C: ";
cin >> border_C;
for (int i = 0; i < numOfEl; i++)
cin >> array_X[i];
prevNum = border_C;
for (int i = 0, j = 0; i < numOfEl; i += 2)
if (array_X[i] < border_C && array_X[i] != prevNum)
array_Y[j++] = prevNum = array_X[i];
cout << endl;
for (int i = 0; i < numOfEl; i++)
cout << array_X[i] << "; ";
cout << endl;
for (int i = 0; i < numOfEl / 2; i++)
cout << array_Y[i] << "; ";
system("pause");
return 0;
} /* End of the 'main' function */