В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Fynerka
Fynerka
28.07.2021 02:38 •  Информатика

13. дано число n. составьте программу для вычисления суммы: s = 1 + 2 + 3 + + n. 14. составьте программу в gpaph abc. нарисовать ряд закрашенных в зеленый цвет кругов радиуса 20 пикселей вдоль верхнего края экрана монитора 16. составьте программу для вычисления числа n: n = 1∙2∙3∙…∙х. число х вводится с клавиатуры.

Ответ:
eevelinka742
eevelinka742
03.08.2020 14:38
program summa;
var
sum:BigInteger;
i,n:integer;

begin
write ('n = ');
readln(n);  
sum:=0;    
i:=1;       
while i<= n do begin 
sum:=sum+i;         
i:=i+1;    
end;
writeln('Sum = ',sum);
end.


program krugi;
uses graphabc;
var
x,y,r:integer;

begin
setBrushColor(clGreen);  
x:=22; y:=22; r:=20;  
while x<660 do    begin     
circle(x,y,r);  
x:=x+40;        
end;
end.


program factorial;
var
pr:BigInteger;
i,n:integer;

begin
write ('n = ');
readln(n);  
pr:=1;    
i:=1;       
while i<= n do begin 
pr:=pr*i;         
i:=i+1;    
end;
writeln('Факториал числа n! = ',pr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?