В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
savelevad120
savelevad120
14.06.2021 12:15 •  Информатика

Написать программу в лазарусе. дана строка. написать программу,которая находит и заменяет во всей строке цифры от 0 до 9 на слова "ноль", "один" "девять". преобразованную строку вывести на екран.

Ответ:
dan5259oxnhwz
dan5259oxnhwz
06.10.2020 11:15
Var
   S:string;
   i:integer;
begin
  ReadLn(S);
  i:=1;
  While i<=Length(S) do
     Begin
     if ('0'<=S[i])and(S[i]<='9') then
        Case S[i] of
        '0':
           Begin
             Delete(S,i,1);
             Insert('ноль',S,i);
           end;
        '1':
           Begin
             Delete(S,i,1);
             Insert('один',S,i);
             i:=i+3
           end;
        '2':
           Begin
             Delete(S,i,1);
             Insert('два',S,i);
             i:=i+2
           end;
        '3':
           Begin
             Delete(S,i,1);
             Insert('три',S,i);
             i:=i+2
           end;
        '4':
           Begin
             Delete(S,i,1);
             Insert('четыре',S,i);
             i:=i+5
           end;
        '5':
           Begin
             Delete(S,i,1);
             Insert('пять',S,i);
             i:=i+3
           end;
        '6':
           Begin
             Delete(S,i,1);
             Insert('шесть',S,i);
             i:=i+4
           end;
        '7':
           Begin
             Delete(S,i,1);
             Insert('семь',S,i);
             i:=i+3
           end;
        '8':
           Begin
             Delete(S,i,1);
             Insert('восемь',S,i);
             i:=i+5
           end;
        '9':
           Begin
             Delete(S,i,1);
             Insert('девять',S,i);
             i:=i+5
           end;
        end;
        i:=i+1
        End;
  WriteLn(S);
  ReadLn;
end.

Для того, чтобы данная программа заработала, нажмите: Файл → создать → простейшая программа.

Если русские буквы отображаются правильно, нажмите правой кнопкой мыши по коду, выберите: параметры файла → кодировка → Ansi (cp1251).
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?