В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SofiyaSofiaro
SofiyaSofiaro
12.04.2021 07:12 •  Информатика

Даны натуральное число n, действительные числа a₁, a₂, . написать программу на языке программирования pascal для вычисления

Ответ:
lianabalkoewa
lianabalkoewa
10.08.2020 06:52
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  Writeln('Вводите a1, a2, ...: ');
  Writeln(sqrt(ReadSeqReal(n).Select(x->x*x).Sum))
end.

Пример
n= 4
Вводите a1, a2, ...:
3 2.5 6.1 -5.2
8.9162772500635
0,0(0 оценок)
Ответ:
DathVayolet
DathVayolet
10.08.2020 06:52
Var
   A:array[1..10000] of real;
   i,n:integer;
   S:real;
Begin
Randomize;
Write('n = ');ReadLn(n);
S:=0;
Write('Исходный массив A(',N,'):');
For i:= 1 to N do
    Begin
    A[i]:=random*(N*2+1)-N;
    Write(' ',A[i]:0:3);
    S:=S+A[i]*A[i];
    End;
WriteLn;
S:=Sqrt(S);
WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?