В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
cisjxhskxhha
cisjxhskxhha
30.08.2020 21:44 •  Информатика

Составить программу: 1. организовать одномерный массив из n элементов 2. организовать двоичный поиск заданного элемента.

Ответ:
Sdkaj
Sdkaj
05.10.2020 01:42
//Dev-C++ 5.11

#include <stdio.h>
int binaryFounder(int*,int,int,int,int*);

int main(void)
 {int ar[100],n,res=-1,i,j,buf,val,arind[100];
 scanf("%d",&n);
 for(i=0;i<n;i++)
  scanf("%d",&ar[i]);
 printf("Enter searching value:");
 scanf("%d",&val);
 for(i=0;i<n;i++)
  arind[i]=i;
 for(i=0;i<n-1;i++)
  for(j=i+1;j<n;j++)
   if(ar[i]>ar[j])
    {buf=ar[i];
    ar[i]=ar[j];
    ar[j]=buf;
    buf=arind[i];
    arind[i]=arind[j];
    arind[j]=buf;}
 binaryFounder(ar,0,n-1,val,&res);
 if (res==-1)
  printf("Not found");
 else
  printf("Found in position %d",arind[res]);
 return 0;}

int binaryFounder(int ar[],int left,int right,int val,int* res)
 {int kar=(left+right)/2;
 if (*res!=-1)
  return 0;
 if (left>right)
  return 0;
 if (ar[kar]==val)
  *res=kar;
 if (ar[kar]<val)
  binaryFounder(ar,kar+1,right,val,res);
 if (ar[kar]>val)
  binaryFounder(ar,left,kar-1,val,res);}

Пример ввода:
5
1
2
3
4
5
4
Пример вывода:
Found in position 3 //считаем с 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?