В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DanProGold
DanProGold
01.10.2021 05:00 •  Информатика

Дан массив из 30 чисел, они могут быть от -1000 до 1000. напишите программу, которая найдет и выведет на экран среди этих чисел максимальное отрицательное число, не оканчивающееся на 3.

Ответ:
Рано007
Рано007
06.10.2020 06:27
VAR
A: ARRAY [1..30] OF INTEGER;
i, max: INTEGER;
BEGIN
FOR i := 1 TO 30 DO READ (A[i]);
max := -1001;
FOR i := 1 TO 30 DO
 IF (A[i]<0) AND (A[i]>max) AND (A[i] MOD 10 <>3) THEN 
 max := A[i];
WRITELN (max);
END.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?