В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rodionowa2003
rodionowa2003
20.05.2021 02:31 •  Информатика

Написать программу (желательно на питоне) или на любом языке про температуру
: известны дневные и ночные температуры мая. определить дни, когда перепад
температур был максимальным.

Ответ:
ds0708
ds0708
10.10.2020 06:56

Написано на Pascal

var

 Night:array [1..31] of integer ; //Массив с ночными температурами

 Day:array[1..31] of integer; //Массив с дневными температурами

 i,dif: integer;

begin

 dif:=0; // Разница

 for i:=1 to 31 do // Цикл заполняющий дневные и ночные температуры(Тут без отрицательных температур)

 begin  

   Night[i]:=random(30); // Рандомная ночная температура

   Day[i]:=random(30); // Рандомная дневная температура

 end;

 for i:=1 to 31 do // Цикл, который ищет максимальную разницу

   if (Day[i]-Night[i])>=dif then

   begin  

     dif:=Day[i]-Night[i];

   end;

 for i:=1 to 31 do // Цикл, который выводит дни с максимальной разницей

 if dif=(Day[i]-Night[i]) then

 writeln('Разница '+dif+'; '+i+' Мая');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?