В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дано целое двузначное положительное число n . составьте программу, которая определяет, входят ли в него цифры 2 и 5

Ответ:
Тина551
Тина551
06.10.2020 05:59
Var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if (a1=2)or(a2=2)
 then writeln('В числе есть цифра 2');
if (a1=5)or(a2=5)
 then writeln('В числе есть цифра 5');
if (a1<>2)and(a2<>2)and(a1<>5)and(a2<>5)
 then writeln('В числе нет цифр 2 и 5');
end.

Пример:
a = 25
В числе есть цифра 2
В числе есть цифра 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?