Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lennyface228
24.02.2023 10:30 •
Информатика
Задать массив из 10 чисел с клавиатуры ,подсчитать произведение положительных элементов массива. ,!
Ответ:
олька9992
06.10.2020 04:31
Uses Crt;
Const
N = 10;
Var
A:array[1..N] of integer;
i:integer;
P:real;
Begin
ClrScr;
P:=1;
Write('Введите массив A(',N,'): ');
For i:= 1 to N do
Begin
Read(A[i]);
if A[i] > 0 then P:=P*A[i];
End;
Write('P = ',P);
ReadLn;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
janaljubche
05.11.2021 20:59
Программа паскаль пользователь вводит число. сколько раз из цифр числа можно составить число 23 - столько раз вывести выведено число 23...
varich83
05.11.2021 20:59
Программа паскаль пользователь вводит число. вывести на экран сколько раз в числе встречаются подряд идущие цифры 23...
5656200
05.11.2021 20:59
Дано число. поменять первую и последнюю цифру местами, если они не равны друг другу. паскаль)...
olga170103
05.11.2021 20:59
Написать программу в паскале. по заданному числу n определите знак числа. формат входных данных: во входном файле input.txt записано одно целое число n (-10000 =n...
89521706957
20.06.2022 16:43
Составьте программу вычисляющую сумму квадратов всех чисел от 1 до n...
blecstar2000
20.06.2022 16:43
Напишите программу определяющую сумму всех нечетных чисел от 1 до 99...
Nastyaninisvn
19.08.2021 02:51
10. Скорость передачи данных по сети Wi-Fi равна 5 Мбит/с. За сколько секунд удастся передать видеофайл объёмом 25⋅106 байт?...
shopiakprod
03.04.2020 12:17
Определите количество натуральных чисел, удовлетворяющих неравенству: 111100101(2) x fc(16)...
pytbrain2007
15.08.2020 23:47
Номер 118. решите . отмечу как лучший ответ. 3-4 класс....
KLerK11
12.04.2023 06:22
Чому м яч, який занурили у воду й відпустили, вискакує над поверхнею води?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Const
N = 10;
Var
A:array[1..N] of integer;
i:integer;
P:real;
Begin
ClrScr;
P:=1;
Write('Введите массив A(',N,'): ');
For i:= 1 to N do
Begin
Read(A[i]);
if A[i] > 0 then P:=P*A[i];
End;
Write('P = ',P);
ReadLn;
End.