В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olga170103
olga170103
05.11.2021 20:59 •  Информатика

Написать программу в паскале. по заданному числу n определите знак числа. формат входных данных: во входном файле input.txt записано одно целое число n (-10000< =n< =10000) формат выходных данных: если заданное число положительное, то в выходной файл output. txt выведите квадрат этого числа. если заданное число отрицательное, то вывелите модуль этого числа. если же заданное число - нуль , то и вывести надо нуль. примеры: input.txt output.txt 5 25 -5 5 0 0

Ответ:
celentano1
celentano1
19.07.2020 15:23
Это если алгоритм выполнить дословно:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, 'input.txt'); Reset(f1);
  Assign(f2, 'output.txt'); Rewrite(f2);
  Readln(f1, n);
  if n < 0 then Writeln(f2, abs(n))
  else
  if n = 0 then Writeln(f2, 0)
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.

А это, если учесть, что модуль нуля равен нулю:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, 'input.txt'); Reset(f1);
  Assign(f2, 'output.txt'); Rewrite(f2);
  Readln(f1, n);
  if n <= 0 then Writeln(f2, abs(n))
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?