Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sanymoskva
07.01.2023 03:48 •
Информатика
Составьте программу получения в порядке убывания всех делителей данного числа n. число n вводится с клавиатуры. .
Ответ:
nadia6191
06.10.2020 04:23
Var n,i:integer;
begin
write('n = ');
readln(n);
writeln('Делители числа ',n,':');
for i:=n div 2 downto 1 do
if n mod i=0 then write(i,' ');
end.
Пример:
n = 24
Делители числа 24:
12 8 6 4 3 2 1
0,0
(0 оценок)
Популярные вопросы: Информатика
настя7187
06.07.2021 08:24
решить задачу по С++. Не могу решить, ничего не выходит....
натахасуслик
30.11.2021 13:03
Флеш-карта имеет объём 8 Гбайт. Рукопись автора содержит 4096 страниц. На каждой странице 1024 строк, в каждой строке 128 символов. Каждый символ кодируется 16 битами. Кроме того,...
Aleksstak
20.03.2020 12:16
Наведи приклад алгоритму із розгалуженням у прислів’ї...
ulia09200413
12.12.2020 19:05
решается моя оценка по информатике...
valentinadeva2p0arnh
16.03.2020 20:02
Каждая буква слова «ремесло» написана на отдельной карточке, затем карточки перемешаны. вынимаем три карточки наугад. какова вероятность получить слово «лес»...
ооардпт
01.05.2022 15:29
Составить алгоритм конечное слово утро...
disapitr
01.05.2022 15:29
Каково наименьшее целое число х, при котором ложно высказывание (10(x+1)*(x+1)-x))...
tyomking
02.06.2020 23:19
Какие компьютерные программы бывают?...
pspoff
20.09.2022 13:27
Быстро зашли и сделала пон ок пок...
milenkakonfetka
25.07.2020 19:04
Найди значение выражения 7,7−(−9,3)....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('n = ');
readln(n);
writeln('Делители числа ',n,':');
for i:=n div 2 downto 1 do
if n mod i=0 then write(i,' ');
end.
Пример:
n = 24
Делители числа 24:
12 8 6 4 3 2 1