В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nezik
Nezik
29.06.2020 20:33 •  Информатика

Решать на pascal abc.net версия 3.2 сборка 1417. написать программу, которая выполняет сравнение многоразрядных десятичных целых чисел. то-есть вывести > если первое число больше второго; вывести < если второе число больше первого; вывести = если числа равны.

Ответ:
Ларибум
Ларибум
06.10.2020 04:00
Var a,b:uint64;
Begin
Write('Введите два целых числа: ');ReadLn(a,b);
if a > b then Write(a,' > ',b)
else if a < b then Write(a,' < ',b)
     else Write(a,' = ',b)
End.
0,0(0 оценок)
Ответ:
Книжнаябабочка
Книжнаябабочка
06.10.2020 04:00
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017

begin
  var a:=ReadlnString('1-е число:').ToBigInteger;
  var b:=ReadlnString('2-е число:').ToBigInteger;
  if a>b then Writeln('>')
  else
    if a=b then Writeln('=')
    else Writeln('<')
end.

Пример
1-е число: 45685695606778795409839437392759354
2-е число: 8643603434233452532223423423525
>

Замечание: разрядность чисел - произвольная.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?