В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
asaparova80
asaparova80
28.11.2020 07:03 •  Информатика

Нужна : ) напишите программу вывода на экран элементов одномерного целочисленного массива из 25-ти элементов и нахождения числа элементов этого массива, которые при делении на 5 остаток 2. элементы массива генератором случайных чисел.

Ответ:
КОте2004
КОте2004
06.10.2020 03:57
Var max,min,i,s:integer;
mas:array[1..25] of integer;
begin
randomize;
write('Введите диапазон: '); readln(max,min);
if(min>max) then begin
max:=max+min;
min:=max-min;
max:=max-min;
end;
for i:=1 to 25 do
mas[i] := min + random(max-min+1);
for i:=1 to 25 do begin
write(i,'-ый элемент: ',mas[i]);
if((mas[i] mod 5) = 2) then begin s:=s+1; writeln('+'); end
else writeln();
end;
write('Сумма элементов, которые при делении на 5 дают остаток 2: ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?