В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dasha555m
Dasha555m
26.07.2022 20:12 •  Информатика

Написать программу, подсчитывающую среднее всех элементов массива [1..5]

Ответ:
АннаКлимчук1997
АннаКлимчук1997
06.10.2020 03:00
Const
   N = 5;
Var
   A:array[1..N] of integer;
   i:integer;
   P:real;
Begin
Randomize;
P:=1;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(N*2+1);
    Write(' ',A[i]);
    P:=P*A[i];
    End;
WriteLn;
WriteLn('Среднее геометрическое его элементов: ',Power(P,1/N):0:3);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?