В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Valeria151415
Valeria151415
02.04.2020 12:05 •  Информатика

Составить программу в паскале используя функции или процедуры , которая будет вычеслять площадь треугольника по трем сторонам. в программе выполнить проверку существования треугольника

Ответ:
t22422
t22422
31.08.2020 23:28
Function S(a,b,c:real):real;
Var
   p:real;
Begin
p:=(a+b+c)/2;
result:=Sqrt(p*(p-a)*(p-b)*(p-c))
End;

Var
   a,b,c:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if (a<b+c)and(b<c+a)and(c<a+b) then WriteLn('S = ',S(a,b,c))
else WriteLn('Треугольник не существует')
End.

Пример:
a = 3
b = 4
c = 5
S = 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?