В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lilya14kiev
lilya14kiev
08.06.2021 19:58 •  Информатика

Даны значения массива {аi}, i = 0, 10 и переменной х. составьте программу вычисления многочлена 10-й степени по формуле горнера: a10x10 + а9х9 + + а1х + а0 = + а9)х + а8)х + + а1)х + а0.

Ответ:
Kamilla0707
Kamilla0707
20.08.2020 17:12
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

function Horner(Self:sequence of real;x:real):real; extensionmethod;
begin
  Result:=Self.Aggregate(0.0,(p,q)->p*x+q) // коэфф. по убыванию степеней!
end;

begin
  var x:=ReadReal('Укажите значение х:');
  Writeln('Введите коэффициенты в порядке возрастания степеней: ');
  Writeln('Результат: ',ReadArrReal(11).Reverse.Horner(x));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?