В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lgep08jle
lgep08jle
20.01.2021 09:08 •  Информатика

1)написать программу нахождения суммы квадратов чисел от 5 до 25 2) дан массив а, состоящий из 15 целых чисел. заполнен с клавиатуры. найти произведение элементов массива, больших 5. паскаль

Ответ:
Куска
Куска
05.10.2020 23:30
//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    Writeln('суммa квадратов чисел от 5 до 25 =', Range(5, 25).Select(x -> x * x).Sum);
    writeln;
    
    var a := ArrGen(15, i -> ReadInteger('a[' + i.toString() + ']='), 1);
    writeln('произведение элементов массива, больших 5 =', a.Where(x -> x > 5).Aggregate(1, (x, y)-> x * y));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?