Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
evabo00
21.08.2022 10:40 •
Информатика
Напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел;
Ответ:
alehanagaitsewa
05.10.2020 22:55
Var n:integer;
S:real;
Begin
Write('n = ');ReadLn(n);
S:=0;
For n:= 1 to n do
S:=S+n;
WriteLn('а) S = ',S);
S:=0;
For n:= 1 to n do
S:=S+n*n;
WriteLn('б) S = ',S);
End.
0,0
(0 оценок)
Ответ:
katyvolkova81
05.10.2020 22:55
A) begin write(seqgen(readinteger(), x -> x + 1, 0).Sum); end.
б) begin write(seqgen(readinteger(), x -> x * x, 1).Sum); end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vladosik1885
03.05.2020 18:03
1)числовые переменные могут быть: 1.целыми и символьными; 2.истина и ложь; 3.простыми и сложными; 4.целыми и вещественными....
вова966
12.08.2021 20:22
Решить , вообще не смыслю в информатике.) чему равны значения переменных r, a, d? var a, b, c: integer r, d: real; a: = 5; b: = 20; c: = -7; d: = 25; r: = a + (4 * b + c) * d a:...
Andrew1712
16.06.2021 20:45
В каталоге располагаются следующие файлы. Какую информацию о файле top можно получить?...
vanzoca
03.05.2023 22:42
небольшой реферат на тему Информационные процессы...
Vladislav525245264
31.03.2021 00:56
5. определите информационный объем сообщения «вода», записанного с 256 символьного алфавита (кавычки не учитывать)....
aaaaaa29
06.07.2022 21:38
Одним из основных требований к информационному обеспечению1)полезность данных информационной базы2)большой объем информации3)собирание в одной информационной базе информации обо...
2008089
09.12.2021 01:51
4. определите количество символов в сообщении, алфавит которого состоит из 128 символов, информационный объем равен 1120бит....
anna080203
30.01.2022 00:26
Cos⁴a-sin⁴a=cos²a Потрібно довести тотожність...
dostovalovaanast
30.01.2022 00:26
Білім алушы 7-сынып 1-тоқсан бойынша қазақ тілі пәнінен №1 жиынтық бағалауға арналған тапсырмаларБөлім «Ауа райы және климаттық өзгерістер. Фонетика»Оқу мақсаты 7.1.1.1 мәтін үзінділерін...
Alina55332
22.11.2021 20:05
2) Почему мифы народов мира до сих пор интересны людей?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
S:real;
Begin
Write('n = ');ReadLn(n);
S:=0;
For n:= 1 to n do
S:=S+n;
WriteLn('а) S = ',S);
S:=0;
For n:= 1 to n do
S:=S+n*n;
WriteLn('б) S = ',S);
End.
б) begin write(seqgen(readinteger(), x -> x * x, 1).Sum); end.