В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vamagic2001
vamagic2001
02.06.2021 18:26 •  Информатика

Требовалось написать программу, которая вводит с клавиатуры последовательность натуральных чисел, оканчивающихся нулем, и выводит на экран сумму четных чисел среди этой последовательности. известно, что последовательность не пуста и в ней есть четные числа. программист торопился и написал программу неправильно. var a, s: integer; begin readln(a); s: =0; while a> 0 do begin read(a); if a mod 2=0 then s: =s+a; end; writeln(s); end. выполните следующие действия: 1. напишите, что выведет программа при вводе чисел 50 2 14 0. 2. пример такой входной последовательности, при которой программа работает верно. 3. укажите ошибки в программе и исправьте их. для этого для каждой ошибки: выпишите строку, которая написана неправильно и правильный вариант строки.

Ответ:
lydmilagerasim
lydmilagerasim
14.08.2020 21:16
1. Выведет 16
2. 1 14 2 0 - выведет 16
3.  Перемещаем строку read(a); в конец цикла while.
Изменяем while a>0 do на while <> 0 do
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?