В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
камил486
камил486
17.04.2020 16:32 •  Информатика

Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 введите два числа: 15 16 ответ: 15+16=31 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 введите два числа: 5 8 ответ: 5*8=40 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 пока!

Ответ:
petrenko20002
petrenko20002
05.10.2020 22:14
Var a,b,c,x:real;
begin 
repeat 
writeln('Введите тип арифм. операции (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - остановить программу'); 
readln(x); 
if x=1  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a+b;   
writeln('ответ: ',c);   
end; 
if x=2  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a-b;   
writeln('ответ: ',c);   
end; 
if x=3  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a*b;   
writeln('ответ: ',c);   
end; 
if x=4  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a/b;   
writeln('ответ: ',c);   
end; 
if x=0 then writeln('Пока!'); 
until x=0;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?