В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
valeevinsaf
valeevinsaf
06.11.2022 12:24 •  Информатика

Составьте программу вычисления суммы отрицательных элементов в массиве a[1..10]. + сделать чтобы это с .txt файла вводилось. я не знаю как, но тема "работа с текстовыми файлами".

Ответ:
2001maks44
2001maks44
07.10.2020 12:32
Var i,k,s: integer;
    f: text;
begin
  assign(f,'c.txt');
  reset(f);
  s:=0;
  for i:=1 to 10 do
  begin
    read(f,k);
    write(k,' ');
    if k<0 then s:=s+k;
  end;
  close(f);
  writeln;
  writeln('сумма отрицательных: ',s);
end.

Файл c.txt во вложении.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?