В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MostQweek
MostQweek
07.10.2020 09:31 •  Информатика

Впаскале составить программу которая для натуральных чисел m и n находит min(2n,m)*nod(2n,3m)

Ответ:
nadyasvetlakov
nadyasvetlakov
05.10.2020 18:44
PascalABC.NET 3.x

function Gcd(a,b:integer):integer; // НОД
begin
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  Result:=a
end;

begin
  var m,n:integer;
  Read(n,m);
  Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
 
Пример
12 43
72
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?