В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
milankae
milankae
07.05.2020 13:30 •  Информатика

Напишите программу. и блок-схему. вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.

Ответ:
пончоДжян
пончоДжян
09.09.2020 02:07
Uses crt;
const  n = 15;
var  i, imin, imax, m, min, max, j: integer;
  a: array[1..n]of integer;
begin 
Writeln('Введите числа в массив'); 
for i := 1 to n do   
readln(a[i]); 
for i := 1 to n do   
write(a[i], '   '); 
min := a[1]; 
max := a[1]; 
imin := 1;
imax := 1;  
for j := 1 to n do 
begin   
if(a[j] > max) then  
begin    
max := a[j];     
imax := j;   
end;   
if(a[j] < min) then   
begin     
min := a[j];     
imin := j;   
end; 
end; 
writeln(); 
writeln('индекс минимального элемента ', imin, ' индекс максимального элемента ', imax); 
m := abs(imin - imax); 
Writeln(); 
Writeln('Кол-во элементов между макс. и мин. элементами ', m - 1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?