В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KLIFFEKATERINA
KLIFFEKATERINA
13.04.2023 08:35 •  Информатика

Напишите программу, которая запрашивает одно целое число-номер месяца, и определяет количество дней в этом месяце. при вводе неверного месяца должно быть выведено сообщение об ошибке.

Ответ:
dimok120503
dimok120503
20.08.2020 15:16
Var a,b,c,d,e:real;
begin
b := 30;
c := 31;
d := 29;
e := 28;
writeln('От 1 до 12');
readln(a);
if a = 1 then writeln(c);
if a = 2 then writeln(d,' или ',e);
if a = 3 then writeln(c);
if a = 4 then writeln(b);
if a = 5 then writeln(c);
if a = 6 then writeln(b);
if a = 7 then writeln(c);
if a = 8 then writeln(c);
if a = 9 then writeln(b);
if a = 10 then writeln(c);
if a = 11 then writeln(b);
if a = 12 then writeln(c);
else writeln('Неправильно');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?