В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
00002017
00002017
16.09.2020 23:21 •  Информатика

Массив из 10 элементов вводится с клавиатуры. составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Ответ:
Ванёк20061
Ванёк20061
15.09.2020 11:27
Шо-то изи

int[] a = new int[10];
Scanner scn = new Scanner(System.in);
for (int i = 0; i < a.length; i++)
a[i] = scn.nextInt();
System.out.println("Input 2 number, to choose numbers from massive");
int b = scn.nextInt();
int c = scn.nextInt();
System.out.println((a[b] + a[c]) / 2);

Проверка:
$ javac Main.java
1 2 3 4 5 6 7 8 9 10
1 5
4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?