В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
katgri83
katgri83
01.07.2022 07:04 •  Информатика

1.напишите программу, вычисляющую значение функции: y =5 при x< 2 2 при x=2 10 при x> 2(программа паскаль) 2.дан условный оператор: if a< 7 then c: =10 else if a> 7 then c: =2 else c: =5 какое значение имеет переменная а, если в результате выполнения условного оператора переменной с присваивается значение 5? (программа паскаль)

Ответ:
Sharjnik
Sharjnik
26.08.2020 09:28
Var
Y,X:real;
Begin
Write('X = ');ReadLn(X);
if X<2 then Y:=5
else if X=2 then Y:=2
     else Y:=10;
WriteLn('Y = ',Y);
End.

2)

c = 5, когда не выполняется оба условия, то есть:

If a<7 then c:=10        // a>=7
else if a>7 then c:=2    // a>7
else c:=5

Переменная a может иметь любое значение больше семи.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?