В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
камидь
камидь
12.04.2022 23:22 •  Информатика

Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. напишите программу, которая получает с клавиатуры натуральное число и определяет, есть ли в его десятичной записи одинаковые цифры, стоящие рядом.

Ответ:
jskzva1
jskzva1
05.10.2020 16:00
Var
N,A:integer;
Begin
Write('N = ');Read(N);
A:=0;
While N>0 do
   Begin
   if (N mod 10) > A then A:= N mod 10;
   N:=N div 10;
   End;
Write(A)
End.

Var
N,A,B:integer;
C:boolean;
Begin
Write('N = ');Read(N);
A:=-1;
B:=-2;
C:=false;
While N>0 do
   Begin
   if A=B then C:=true;
   if N>0 then
      Begin
      A:=N mod 10;
      N:=N div 10;
      End;
   if A=B then C:=true;
   if N>0 then
      Begin
      B:=N mod 10;
      N:=N div 10;
      End;
   End;
if A=B then C:=true;
if C then Write('Есть')
else Write('Нет')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?