В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
хава993
хава993
04.07.2022 10:39 •  Информатика

Все богом молю написать программу на языке с дано число x. напечатать в порядке возрастания ln(x), 1+|x|, (1+x^2) x p s только не надо как обычно бред писать ради

Ответ:
Apelsinka0986
Apelsinka0986
20.08.2020 22:58
#include <stdio.h>
#include <math.h>

int main()
{
float x, y1, y2, y3; 
scanf("%f",&x);
y1 = log(x);
printf("Ln(x) = %f\n", y1);
y2 = 1+fabs(x);
printf("1+|x| = %f\n", y2);
y3 = (1+x*x)*x;
printf("(1+x^2)*x = %f\n", y3);
if ((y1<y2)&&(y1<y3)) {
if (y2<y3) printf("%f  %f  %f", y1,y2,y3);
else printf("%f  %f  %f", y1,y3,y2);
}
else if ((y2<y1)&&(y2<y3)) {
if (y1<y3) printf("%f  %f  %f", y2,y1,y3);
else printf("%f  %f  %f", y2,y3,y1);
}
else if (y1<y2) printf("%f  %f  %f", y3,y1,y2);
else printf("%f  %f  %f", y3,y2,y1);
return 0;
}

Пример:
0.8
Ln(x) = -0.223144
1+|x| = 1.800000
(1+x^2)*x = 1.312000
-0.223144 1.312000 1.800000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?