В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yanaolok
yanaolok
11.01.2023 01:27 •  Информатика

Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и вывести на экран сообщение.и определить заканчивается эта сумма на 3,является ли эта сумма четным

Ответ:
vany4189
vany4189
05.10.2020 15:06
//PascalABC.Net 3.2
begin
var x:=readinteger ('Введите x: ');
var sum:=0;
repeat
sum+=x mod 10;
x:=x div 10;
until x=0;
writeln ('Сумма цифр: ', sum);
writeln ('Сумма заканчивается на 3: ', (sum mod 10)=3);
writeln ('Сумма четная - ', sum.Iseven);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?