Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
mightwood1337
01.11.2022 14:11 •
Информатика
Напишите функцию которая вычисляет сумму чисел от a до b (pascal abc)
Ответ:
Like2942
05.10.2020 14:01
Function isch(a,b: integer): integer;
var i,sum: integer;
begin
sum:=0;
for i:=a to b do sum:=sum+i;
isch:=sum;
end;
0,0
(0 оценок)
Ответ:
Nastyushon
05.10.2020 14:01
Function SumAB(a,b:integer):integer;
begin
SumAB:=(a+b)*(b-a+1) div 2
end;
var
a,b:integer;
begin // тестирование
Read(a,b);
Writeln('Сумма от ',a,' до ',b,' равна ',SumAB(a,b))
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
hristina112
12.11.2022 14:03
Как узнать вес одного символа ? например обьясните мне : мощность алфавита 64 (это n=6) почему 6?...
navozovaleksejj
20.07.2021 16:12
Нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным...
roma9jko
29.06.2021 18:44
Совместимы ли Материнская плата ASRock B450M Pro4 и 480 ГБ SSD M.2 накопитель Kingston A400 [SA400M8/480G]...
Lolka200Fantazii0
07.07.2021 19:18
Числа трибоначчи — это последовательность целых чисел, которая определяетя так: первое, второе и третье числа трибоначчи равны единице; каждое число трибоначчи равно...
kupecki
07.07.2021 19:18
1)вывести на экран сообщение неllо (программирование паскаля) 2) вывести на экран три введённых числа...
RedGirl12
07.07.2021 19:18
Склавиатуры вводятся два числа вывести на экран сумму.результата деления этих чисел...
Uoywex
27.05.2023 13:37
Удвоить трехзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае. если введенное число...
lalka137
27.05.2023 13:37
Что делает в программе следующая строка? for i: =1 to 10 do read(m[i]); а) пересчет массива от 1 до 10; b) заполнение массива; c) ввод в массив десяти имен переменных;...
хотам3
02.12.2021 23:31
Один кран наповнює 6 год, а другий 4 год. Яку частину баку наповнять два крани за 1/2 години, працюючи разом?...
newsergy81
02.12.2021 23:31
Вычислите массу кислорода необходимого для получения 1,5 моль оксида алюминия. с дано, с формулами и с решением...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var i,sum: integer;
begin
sum:=0;
for i:=a to b do sum:=sum+i;
isch:=sum;
end;
begin
SumAB:=(a+b)*(b-a+1) div 2
end;
var
a,b:integer;
begin // тестирование
Read(a,b);
Writeln('Сумма от ',a,' до ',b,' равна ',SumAB(a,b))
end.