В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ааа511
ааа511
10.07.2020 14:20 •  Информатика

Написать программу в паскале дан целочисленный массив. он заполняется при запуске программы: сначала запросить число элементов (n от 1 до 40), затем - элементы – целые числа в интервале от -500 до 500. a. количество чисел, оканчивающихся на 3; b. найти среднее арифметическое всех положительных элементов массива, которые кратны первому элементу (делятся нацело на первый элемент). гарантируется, что первый элемент массива положительный. c. наибольший отрицательный элемент, который делится на 3.

Ответ:
viktoriacotik1
viktoriacotik1
05.10.2020 13:47
Var
  a:array[1..40] of integer;
  i,n,k3,k,s,a3:integer;
begin
  Write('n='); Read(n);
  for i:=1 to n do Read(a[i]);
  k3:=0; {a}
  s:=0; k:=0; {b}
  a3:=-1000; {c}
  for i:=1 to n do begin
    if a[i] mod 10=3 then Inc(k); {a}
    if (a[i]>0) and (a[i] mod a[1]=0) then begin {b}
      s:=s+a[i]; Inc(k)
      end;
    if (a[i]<0) and (a[i]>a3) and (a[i] mod 3=0) then a3:=a[i]; {c}
    end;
  Writeln('Кол-во чисел. оканчивающихся на 3: ',k3); {a}
  Writeln('Среднее арифметическое по условию: ',s/k:0:3); {b}
  if a3<>1000 then Writeln('Наибольший отрицательный, кратный 3: ',a3) {c}
  else Writeln('Нет отрицательных элементов, кратных 3')
end.

Для решения конкретного пункта выбирать только операторы, помеченные этим пунктом, Например, {a} для а)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?