Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
annavelikks03
09.07.2020 04:18 •
Информатика
Воднородном массиве найдите произведение ненулевых элементов
Ответ:
Shaxrior
05.10.2020 12:26
Program n1;
const n=10;
var a: array [1..n] of integer;
i,p: integer;
begin
p:=1;
for i:=1 to n do readln(a[i]);
for i:=1 to n do if a[i]<>0 then p:=p*a[i];
writeln(p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nnejman
18.04.2023 13:56
52 mod 3 + 10 div 2*2 – 14 mod 3 б даю...
AndreySolmikov
19.07.2022 11:19
Язык C# Сделать блок-схему для данной программы желательно в Word, ниже прикрепил фотографию с тем заданием, по которому была написана эта программа using System; using System.Collections;...
fedosovdenis28
15.10.2021 03:35
Напишите следующие три класса: Book, Саг, Phone Классы должны содержать не менее трех свойств (на ваше усмотрение) Добавьте в классы следующие методы: а) Геттеры и сеттеры...
даша3648
28.02.2021 16:08
Определить количество членов в последовательности натуральных чисел кратных числу M и заключенных в интервале от L до N Нужно сделать в Pascal...
vipmopmop
01.04.2022 06:24
Написать программу, которая вычисляет сумму первых n нечётных натуральных чисел(паскаль). например, если n=3 то ответ 9 т.е 1+3+5...
Uliana7003
01.04.2022 06:24
Сколько символов содержит сообщение записанное с 16 символьного алфавита если его объем составил одну шестнадцатую часть мегабайта...
Cekretcv
26.09.2021 12:01
Описать функцию MaxN(A, N) целого типа, находящую номер максимального элемента вещественного массива A размера N. С этой функции найти номера максимальных элементов массивов...
dmitriyvoron8
11.02.2020 11:33
Дано пятизначное чило N. Если оно кратное 3 , вычислить выражение n^2-3 корень n иначе вычислить [n]/3n+ чило Пи и вывести сообщение об этом в паскале...
KrisChuHD
12.11.2022 22:24
Превратите целые числа из десятичной системы счисления в двоичную а) 89 ; б)600 в)2010...
помошник137
12.11.2022 22:24
Какие основноые группы клавиш можно выделить на клавиатуре и каково их назначение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const n=10;
var a: array [1..n] of integer;
i,p: integer;
begin
p:=1;
for i:=1 to n do readln(a[i]);
for i:=1 to n do if a[i]<>0 then p:=p*a[i];
writeln(p);
end.