Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
kristinabuslae
08.09.2020 00:38 •
Информатика
Водномерном массиве найти произведение ненулевых элементов ( задать рандомно )
Ответ:
Urinasonya
05.10.2020 12:30
Program n1;
const n=10;
var a: array [1..n] of integer;
i,p: integer;
begin
randomize;
p:=1;
for i:=1 to n do a[i]:=random(10);
for i:=1 to n do if a[i]<>0 then p:=p*a[i];
writeln(p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dasha43com
20.02.2023 22:12
1. даны два ненулевых числа а и b. напишите программу для нахождения суммы, разности, произведения и частного. 2. напишите программу для нахождение периметра и...
dima2727
09.09.2021 11:13
Написать программу, которая делает следующее: 1) спрашивает у пользователя кол-во чисел 2) после того, как пользователь ввел нужно кол-во чисел, программа выводит...
KAKAKALYYA12
23.07.2020 12:36
Что нужно сделать чтобы повернуть фрагмент на 90 градусов...
Tolya567
14.09.2022 12:16
Для какого из указанных значений числа x истинно выражение (x 3) и ((х 2) или (х !...
MilkyWay3355
10.07.2022 07:06
Напишите наименьшее целое число х, для которого истинно высказывание: не (х 9 и не (х нечетное) сс по инфе...
alina56737
02.03.2022 09:39
Объясните, почему именно так логическая функция, какой закон используется...
ivannaprokuror
10.02.2023 09:32
Саша играет в баскетбол в серии из 20 бросков у нее было 55% прпаланий,а после 5 следующих бросков общий процент попаланий вырос до 56% ск2 из этих последних 5...
BubbleRise
07.11.2020 08:31
Утебя письмо от друга. напиши ей письмо и ответь на четыре вопроса. напишите 50-60 слов. чем вы обычно занимаетесь по выходным? какое ваше любимое место в районе?...
Пашаg
12.11.2021 04:31
Найдите все натуральные трёхзначные числа которые можно записать цифрами 3 и4и8...
соняка2008
22.05.2022 03:37
Найти производную x = a cos^2 t, y = b sin^2 t(это один пример)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const n=10;
var a: array [1..n] of integer;
i,p: integer;
begin
randomize;
p:=1;
for i:=1 to n do a[i]:=random(10);
for i:=1 to n do if a[i]<>0 then p:=p*a[i];
writeln(p);
end.