Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
fenx73
17.01.2022 20:54 •
Информатика
Написать функцию нахождения кол-ва цифр через рекурсию. паскаль. рекурсия. через функцию.
Ответ:
aspier2016
05.10.2020 12:22
Var a:integer;
function k(n:integer):integer;
begin
if n<10
then k:=1
else k:=k(n div 10)+1;
end;
begin
write('a = ');
readln(a);
writeln('Количество цифр = ',k(a));
end.
Пример:
a = 134652
Количество цифр = 6
0,0
(0 оценок)
Ответ:
VladSuperMozg
05.10.2020 12:22
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!
function DigCnt(n:integer):integer:=(n<10?1:DigCnt(n div 10)+1);
begin
var k:=ReadInteger('Введите целое неотрицательное число');
if k>=0 then Writeln('Цифр в числе: ',DigCnt(k))
end.
Пример
Введите целое неотрицательное число 14206423
Цифр в числе: 8
0,0
(0 оценок)
Популярные вопросы: Информатика
Eskhere
07.08.2022 09:40
Там где цифру не видно в самом конце там цифра 2...
Nicalay
21.01.2022 17:21
Синформатикой . заранее большое ))...
mamanazaruz60
24.01.2020 16:58
Что значит 800 и (400),озу kingston ddr2 800 (400мгц)? ...
Litegran
04.06.2023 22:28
Написать программу по определению четности или нечетности числа. число вводится с клавиатуры. 17+9...
njjk1
10.03.2022 16:43
Вкоробке лежат 32 карандаша. сообщение о том, что достали зеленый карандаш, несет 2 бита информации. сколько зелёных карандашей в коробке?...
BWorld
10.03.2022 16:43
Дети в 4 кассе должны читать 170 символов в минуту.предположим, что при записи текста использовался 32 символьный алфавит. какой объём информации должен получить...
gulyaaxundova
28.01.2022 16:23
Задали нарисовать плакат на любую тему.я решила написать про интернет.на плакате должен присутствовать заголовок,подзаголовок,графический объект,текст.( подобрать...
alinaburlaka
28.01.2022 16:23
Назовите (это по информатике) 1)устройства обработки информации, 2)устройства передачи информации, 3) устройства мультимедийной обработки информации....
leralerochka202
09.03.2023 05:48
Нам задали отгадать красворд ! я все слова отгадала но 1 слово не смогла ! ! каждый элемент списка имеет ( 5 букв )...
mmmm52
20.02.2020 09:56
Составить алгоритм квадратного уравнения...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
function k(n:integer):integer;
begin
if n<10
then k:=1
else k:=k(n div 10)+1;
end;
begin
write('a = ');
readln(a);
writeln('Количество цифр = ',k(a));
end.
Пример:
a = 134652
Количество цифр = 6
// Внимание! Если программа не работает, обновите версию!
function DigCnt(n:integer):integer:=(n<10?1:DigCnt(n div 10)+1);
begin
var k:=ReadInteger('Введите целое неотрицательное число');
if k>=0 then Writeln('Цифр в числе: ',DigCnt(k))
end.
Пример
Введите целое неотрицательное число 14206423
Цифр в числе: 8