Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
NastyaZl
07.02.2022 08:05 •
Информатика
Даны два одномерных массива из целых чисел разной размерности найти среднее арифметическое элементов каждого массива и их сумму
Ответ:
migmo5
24.04.2020 15:09
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
var b:=ArrRandom(ReadInteger('n='),-99,99); b.Println;
(var ma,var mb):=(a.Average,b.Average); // средние арифметические
var s:=ma+mb; // их сумма
Writeln('Среднее арифметическое массива а: ',ma);
Writeln('Среднее арифметическое массива b: ',mb);
Writeln('Их сумма: ',s)
end.
Пример
n= 12
9 -55 -14 -60 -90 56 60 -89 -9 18 -37 -29
n= 15
47 -53 4 22 38 -46 -74 -77 -74 -67 -67 -93 73 5 -16
Среднее арифметическое массива а: -20
Среднее арифметическое массива b: -25.2
Их сумма: -45.2
0,0
(0 оценок)
Популярные вопросы: Информатика
timca2014
02.06.2020 06:42
Найти сумму случайных чисел до тех пор пока не выпадет 0 каждая из случайных чисел вывести на экран...
Иванджелина
02.06.2020 06:42
Напишите программу которая выводит на экран значение переменной s : a+в а*в а и в водяться с клавиатуры...
Sofiko20017
04.11.2022 13:34
Почему не работает программа по нахождению полиндрома через массив? ? не понимаю? ? const n=5; var a: array[1..n] of char; i,c: integer; begin for i: =1 to n do read...
itkrg
04.11.2022 13:34
Откорректировать программу. нужно, чтобы выводилась сумма элементов массива с четными индексами. т.е., например, в массиве 2 7 8 9 3 - ответ выводится 16. ошибка...
Лилюсечка
04.11.2022 13:34
Путём подбора степеней числа 2 в сумме заданное число переведите в двоичную систему счисления следующие числа: а)5 б)7 в)12 г)25 д)32 е)33...
modinn112
21.05.2021 08:03
Дано n произвольный чисел,найти их сумму (паскаль abc). решить в 3-х циклах,(for; repeat and until; while)...
ffoxyyyy1
07.01.2020 08:11
Как называются технологии, которые позволяют объединять разные формы представления информации (текст, рисунки,звук,видео) в одном документе?...
evstropovi1632
21.02.2021 10:59
Найди периметр квадрата со стороной 8 см 4 мм...
StarSquirrel
26.06.2022 02:54
Найти значение выражения|-72|-|-34|...
adamadam
26.06.2022 02:54
Подчеркни слова которые произнесла катя катя ты в зоопарк хочешь на тигра посмотреть очень хочу подём конечно...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
var b:=ArrRandom(ReadInteger('n='),-99,99); b.Println;
(var ma,var mb):=(a.Average,b.Average); // средние арифметические
var s:=ma+mb; // их сумма
Writeln('Среднее арифметическое массива а: ',ma);
Writeln('Среднее арифметическое массива b: ',mb);
Writeln('Их сумма: ',s)
end.
Пример
n= 12
9 -55 -14 -60 -90 56 60 -89 -9 18 -37 -29
n= 15
47 -53 4 22 38 -46 -74 -77 -74 -67 -67 -93 73 5 -16
Среднее арифметическое массива а: -20
Среднее арифметическое массива b: -25.2
Их сумма: -45.2