В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
spetsialist
spetsialist
17.01.2021 16:21 •  Информатика

Pascal abc напишите программу, которая определяет количество элементов, сумма цифр которых четна. формат ввода программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода). формат вывода выведите одно число – количество чисел, сумма цифр которых четна пример ввод вывод 2 4 3 4 1444 4 5 136 0

Ответ:
dianabalaganska
dianabalaganska
14.08.2020 18:19
Program n1;
var a,k: integer;
function summa( n: integer ): integer;
var s: integer;
begin
s:=0;
while n>0 do
begin
s:=s+n mod 10;
n:=n div 10;
end;
summa:=s;
end;
begin
k:=0;
write('введите 1 число: ');
readln(a);
if (summa(a) mod 2=0) and(a<>0) then k:=k+1;
while a<>0 do
begin
write('введите следущее число: ');
readln(a);
if (summa(a) mod 2=0) and(a<>0) then k:=k+1;
end;
writeln('количество: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?