В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lecsika
lecsika
15.05.2020 12:33 •  Информатика

Напишите программу которая вычисляет сумму отрицательных элементов массива a[20]. массив заполнить случайными числами из [-1000; 1000]

Ответ:
шкальник2281337
шкальник2281337
15.07.2020 10:50
Program Project2;
{$APPTYPE CONSOLE}
uses  SysUtils,windows;constnMin=1;nMax=20;typemas=array[nMin..Nmax] of integer;
Vara:mas; i:integer;s:real;begin  setconsoleCP(1251);  setconsoleOutPutCp(1251);  randomize;

for i:=1 to  nMax doa[i]:=random(1000)-500;writeln ('Ìàññèâ:'); for i:=1 to  nMax do beginwrite ('');write  (a[i]:2);writeln ('');end;s:=0;for i:=1 to Nmax dobeginIf a[i]<0 thens:=s+a[i];end;writeln ('Ñóììà îòðèöàòåëüíûõ ýëåìåíòîâ ìàññèâà = ',s:2:2);readln;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?