В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
swdw1
swdw1
23.02.2020 11:02 •  Информатика

Составить программу в ! дана вещественная матрица размера mxn. определить числа b1, bm, равные произведениям элементов строк.

Ответ:
пппп103
пппп103
05.10.2020 09:44
//PascalABC.NET 3.2 сборка 1318

Const
  n=3;
  m=4;

Var 
 ma:array[1..m,1..n] of integer;
  ar:array[1..m] of integer;
  i,j:integer;
begin
for i:=1 to m do
  begin
    ar[i]:=1;
    for j:=1 to n do
      begin
        readln(ma[i][j]);
        ar[i]*=ma[i][j];
      end;
  end;
writeln('Matrix:');
for i:=1 to m do
  begin
    for j:=1 to n do
      write(ma[i][j]:4);
    writeln;
  end;
writeln('Res:');
for i:=1 to m do
writeln(i,':',ar[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?