В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nasty2204
nasty2204
04.10.2022 13:08 •  Информатика

Написать программу в паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с клавиатуры. после каждого действия вывести полученную сумму, если она меньше max числа

Ответ:
Nik228tyto4ki
Nik228tyto4ki
05.10.2020 08:22
Var max,s:integer;
begin
write('max = ');
readln(max);
s:=1;
while s<=max do
 begin
 write(s,' ');
 s:=s+7;
 end;
writeln;
end.

Пример:
max = 40
1 8 15 22 29 36 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?