В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
innadom34
innadom34
31.12.2022 10:00 •  Информатика

Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число -1, если ни один элемент не повторяется. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести максимальный повторяющийся элемент в массиве или число -1, если ни один элемент не повторяется.

Ответ:
saidos1000
saidos1000
05.10.2020 08:00
Var 
 a:array [1..10000] of integer;
 i,n,a_max,c;
begin
 read(n);
 a_max:=0;
 c:=0;
 for i:=1 to n do 
 begin
  a[i] := random(100); // автозаполнение массива 
  print(a[i]);
  if a[i]>a_max then a_max:=a[i]; // поиск максимального элемента
 end;
 writeln;
 for i:=1 to n do 
  if a[i]=a_max then inc(c); // поиск повторяющихся элементов
 if c>=2 then write(a_max)
 else write(-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?