Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
katya2562
28.06.2020 18:05 •
Информатика
Дан массив а(6). найти сумму и количество положительных элементов, расположенных между минимальным и максимальным элементами.
Ответ:
Юля1ьагааащщн
05.10.2020 07:49
Program example;
const
A=30;
Nmin:=-100; // минимальный параметр
Nmax:=100; //максимальный
var
flag_max : integer;
flag_min : integer;
i. jmin,jmax : integer; //счетчики
Randomize;
array max[A];
//заполняем случайніми числами диапозон -100 +100
for i=1 do A do begin max=:= Random (Nmin + 1) - 2 * Nmax; end;
//ищим максимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_max:=max
jmax:=i; end; else begin flag_max:=max[i+1];
jmax:=i; end; end;
//минимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_min:=max[i+1]
jmin:=i; end; else begin flag_min:=max; jmin:=i; end; end;
//подсчитываем сумму
for i=jmin do jmax-1 do begin max:=max[i+1] end;
//сумма чисел в рандовом массиве между макс и мин єлементом
write('сума',max);
0,0
(0 оценок)
Популярные вопросы: Информатика
vlerut1
03.09.2021 07:06
Эргономика это наука изучающая взаимодействие для благополучия на рабочем месте....
alyonasajko
03.09.2021 07:06
Андрей, боря, витя, гена и дима рисовали зверей. в итоге получилось пять рисунков: черный кот, оранжевый тигр, желтый тигр оранжевый жираф и желтый гепард. определите, кто...
катя5086
02.10.2021 04:15
53) данные объемом 30 мбайт из пункта а в пункт б по каналу связи, обеспечивающему скорость передачи данных 222 бит в секунду, а затем из пункта б в пункт в по каналу связи,...
volk007volk
19.03.2023 11:44
Когда удобно испрльзывать столбчатую диаграмму....
grishaeva79
20.06.2022 15:42
Что будет выведено на экран в результате выполнения фрагмента программы a: =5; b: =3; write( z(a)= , (b) ); здесь a и b — целые переменные....
CloudySun
20.06.2022 15:42
Банкомат написать программу: на вход подаётся число s. выразить данную сумму денег минимальным количеством банкнот по 500, 100, 10, 5, 2,1....
goldfox1
01.09.2020 01:19
Лаб работа номер 2 по информатике институт станкин...
TimRus162rusg
22.12.2021 03:47
Построить логическую схему по формуле (a ∧ b) ∧ (c ∧ b)...
yoanna0900
09.05.2023 20:33
Вчем разница, информатика от информатика и итк? ...
lobanovartem2
28.09.2022 06:43
Дополни предложение, в пустое место впиши (скопируй) правильный ответ из списка, данного ниже. собственную (внутреннюю) память человека, можно назвать , потому что содержащаяся...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const
A=30;
Nmin:=-100; // минимальный параметр
Nmax:=100; //максимальный
var
flag_max : integer;
flag_min : integer;
i. jmin,jmax : integer; //счетчики
Randomize;
array max[A];
//заполняем случайніми числами диапозон -100 +100
for i=1 do A do begin max=:= Random (Nmin + 1) - 2 * Nmax; end;
//ищим максимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_max:=max
jmax:=i; end; else begin flag_max:=max[i+1];
jmax:=i; end; end;
//минимальный элемент
for i=1 do A do begin if max>max[i+1] then begin flag_min:=max[i+1]
jmin:=i; end; else begin flag_min:=max; jmin:=i; end; end;
//подсчитываем сумму
for i=jmin do jmax-1 do begin max:=max[i+1] end;
//сумма чисел в рандовом массиве между макс и мин єлементом
write('сума',max);