В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
CloudySun
CloudySun
20.06.2022 15:42 •  Информатика

Банкомат написать программу: на вход подаётся число s. выразить данную сумму денег минимальным количеством банкнот по 500, 100, 10, 5, 2,1.

Ответ:
Емодзи
Емодзи
03.10.2020 05:01
Program abc;
var a:array[1..6] of integer;
var i,s: integer;
begin
 i:=0;a[1]:=500;a[2]:=100;a[3]:=10;a[4]:=5;a[5]:=2;a[6]:=1;
writeln('Введите целое число,сумму денег:');
readln(s);
while s<>0 do
begin
if s>=a[1] then begin
s:=s-a[1]; i:=i+1; end;
if (s>=a[2]) and (s<a[1]) then begin s:=s-a[2]; i:=i+1; end;
if (s>=a[3]) and (s<a[2]) then begin s:=s-a[3]; i:=i+1; end;
if (s>=a[4]) and (s<a[3]) then begin s:=s-a[4]; i:=i+1; end;
if (s>=a[5]) and (s<a[4]) then begin s:=s-a[5]; i:=i+1; end;
if (s>=a[6]) and (s<a[5]) then begin s:=s-a[6]; i:=i+1; end; 
end;
Writeln('Наименьшее число купюр =',i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?