Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
тоня119
31.07.2021 13:26 •
Информатика
По информатике написать программу в которой будет вычитаться из числа 1000 числа,введённые пользователем с клавиатуры до тех пор, пока разность не станет меньше 0. примечание применить цикл repeat,until буду
Ответ:
lol1044
05.10.2020 07:25
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
begin
var t:=1000;
var k:integer;
repeat
k:=ReadInteger('->');
t-=k
until t<0;
Writeln('Всё...')
end.
Пример
-> 453
-> 216
-> 39
-> 64
-> 312
Всё...
Решение для "древних паскалей"
var
k,t:integer;
begin
t:=1000;
repeat
Write('->'); Read(k);
t:=t-k
until t<0;
Writeln('Всё...')
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Ника1511111
29.05.2020 02:11
1.каково назначение: устройства ввода,устройства вывода,устройства памяти,процессора? какова наименьшая адресуемая часть памяти? 2.как записывается информация в память...
Денок07
03.07.2021 01:48
Число 13(10)=1101(2) в восьмиразрядном представлении имеет вид:...
vika030620071
03.04.2021 03:05
Как играть по сети в survivalcraft? 20...
Bljekmessija
16.02.2022 05:03
Богатырь стоит перед камнем на распутье. на камне надпись: налево пойдешь- жену найдешь, направо пойдешь - богатство найдешь, прямо пойдешь - славу найдешь. сколько...
SVT38
16.02.2022 05:03
Решите это по информатике a^b v a^b...
lnatahozqc8g
16.02.2022 05:03
Файловая система это а) системная программа б) вложенная структура файлов в) вложенная структура папок г) вложенная структура файлов и папок...
davaispi
15.07.2021 10:15
Даны время (два целых числа – часы и минуты). вывести время суток. будем считать, что: утро – от 6: 30 до 10: 00 ; день – от 10: 01 до 16: 30 ; вечер – от 16: 31...
malini20
15.07.2021 10:15
На таймере цифрового устройства, ведущем обратный отсчет секунд, можно устанавливать любое начальное количество секунд. кроме того, по истечении любой очередной секунды...
лыл3
15.07.2021 10:15
Даны пути одной файловой системы c: /экзамен/фото/ф1.doc c: /экзамен/ф2.doc c: /экзамен/ф1.bmp c: /экзамен/фото/ф3.bmp c: /фото/ф4.doc из корневого каталога c: /файл...
ivanBashak1
15.07.2021 10:15
Составить алгоритм вычисления его треугольника площади зная три его стороны...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var t:=1000;
var k:integer;
repeat
k:=ReadInteger('->');
t-=k
until t<0;
Writeln('Всё...')
end.
Пример
-> 453
-> 216
-> 39
-> 64
-> 312
Всё...
Решение для "древних паскалей"
var
k,t:integer;
begin
t:=1000;
repeat
Write('->'); Read(k);
t:=t-k
until t<0;
Writeln('Всё...')
end.