Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
AlicaMinenkova
19.03.2020 13:33 •
Информатика
Составьте программу, которая выводит все делители натурального числа n (в паскале)
Ответ:
ONO2017
26.08.2020 07:26
Var n,i:integer;
begin
write('n = ');
readln(n);
writeln('Делители:');
for i:=1 to n div 2 do
if n mod i = 0 then write(i,' ');
writeln(n);
end.
Пример:
n = 24
Делители:
1 2 3 4 6 8 12 24
0,0
(0 оценок)
Популярные вопросы: Информатика
arinaambrosova
05.04.2023 13:16
В одном множестве 94 элементов, а в другом — 17. Какое максимальное количество элементов может быть в их пересечении?...
rimakarapetyan12
02.03.2023 12:40
Вычислите значение переменных для данных команд присваивания. b:=6412 div 10 - 11. Значение переменной равноx:=6399 mod 10 + 10. Значение переменной хравноn:=384 div 100. Значение...
Ani32536
16.03.2020 23:53
Решите в паскале)) даны координаты вершин прямоугольника а(x1, y1), b(x2,y2), c(x3,y3), d(x4,y4). вычислите периметр и площадь прямоугольника....
AgentDaleCoop
16.03.2020 23:53
Решите в вывести таблицу умножения чисел (от 4 до 10) на число, заданное с клавиатуры....
gfyfhh
10.09.2020 17:50
Даны стороны прямоугольника a и b (вещественные числа, вводятся с клавиатуры). найти его площадь по формуле s=a*b и периметр по формуле p=2*(a+b)....
наталя40
18.10.2021 15:09
Олимпиада! надо быстро решать!...
RzhevskayaL
28.09.2020 03:04
1. сообщение занимает 3 страницы. на каждой странице содержится по 64 символа. объем сообщения составляет 3/64 кбайта. сколько символов содержит алфавит, с которого записано сообщение?...
Roland227
28.09.2020 03:04
2. сообщение, записанное буквами из 16-символьного алфавита, содержит 50 символов. какой объём информации оно несёт?...
VaLeRiA102030405060
04.10.2022 15:31
Do you know many foreign people?-No,i do not .I know very (few/a few)...
ІванДурненький
05.07.2022 23:48
К видам лёгкой атлетики не относится Укажите правильный вариант ответа: прыжки через коня прыжки в длину прыжки в высоту спортивная ходьба...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('n = ');
readln(n);
writeln('Делители:');
for i:=1 to n div 2 do
if n mod i = 0 then write(i,' ');
writeln(n);
end.
Пример:
n = 24
Делители:
1 2 3 4 6 8 12 24