Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Ani32536
16.03.2020 23:53 •
Информатика
Решите в паскале)) даны координаты вершин прямоугольника а(x1, y1), b(x2,y2), c(x3,y3), d(x4,y4). вычислите периметр и площадь прямоугольника.
Ответ:
бабушка111111
02.07.2020 23:57
Var x1,x2,x3,x4,y1,y2,y3,y4:integer;
AB,BC,p,s:real;
begin
read(x1,y1,x2,y2,x3,y3,x4,y4);
AB:=sqrt(sqr(x1-x2)+sqr(y1-y2));
BC:=sqrt(sqr(x2-x3)+sqr(y2-y3));
p:=2*(ab+bc);
s:=ab*bc;
write('p=',p,' s=',s);
end.
0,0
(0 оценок)
Ответ:
amadi888
02.07.2020 23:57
program umn;
var X1,Y1,x2,y2,x3,y3,x4,y4, P,S,l1,l2:real;
begin
write('Введите координаты вершин треугольника ( A, B, C, D): '); read(X1,Y1,x2,y2,x3,y3,x4,y4);
l1 := Sqrt(sqr(x2 - x1) + Sqr(y2-y1));
l2 := Sqrt(sqr(x3 - x2) + Sqr(y3-y2));
S := l1 * l2;
P := 2 * (l1+l2);
write(S:3:2,' ',P:3:2);
end.
Если есть вопросы задавайте.
0,0
(0 оценок)
Популярные вопросы: Информатика
даниля3
03.07.2022 22:37
Какая буква должна стоять вместо знака вопроса пвс ? п с в...
KimTaehyeng
03.07.2022 22:37
Расшифровать азбуку морзе: )) вот: u2fsdgvkx18xtouvdewkjxk5spfkeltm2bot91sh1sjrwqrhf6lc2xmwibafrl4j3 или: ••− ••−−− ••−• ••• −•• −−• •••− −•− −••− •−−−− −−−•• −••−...
askipolina
11.02.2021 13:49
Весна хорошее время года это суждение или нет груша вкуснее канфеты это суждение или нет на улице светит солнце это суждение или нет я ученик 4го класса это суждение...
danilsartakov
11.01.2021 05:08
Ира, боря, и алеша закодировали по одному слову. вот их коды 1011 1111 1011 1110 1011 1011 10110101...
Каке11
19.01.2023 02:38
Напишите программу по информатике python...
lehakharitonov
06.07.2021 19:15
1. Выберите правильные ответы file=open(“test.txt , r ) Что делает эта команда? А) Открывает файл с именем test.txt В) Открывает в режиме чтения C) Открывает файл...
ася992
06.02.2023 21:16
Наведіть приклади подання одного й того самого повідомлення різними дуже треба 40 ів...
Roth999
10.03.2020 20:12
Сколько цветов будет содержать палитра, если каждый пиксель кодировать четырьмя битами?...
andrognew2018
04.12.2021 20:24
До етапів розв язування компетентісних задач відносяться...
garipova02
26.12.2020 14:25
Зайчиха розклала 12 морквинок і 8 бурячків на 4 тарілки порівну скільки овочів наодній тарілці? потрібен короткий запис...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
AB,BC,p,s:real;
begin
read(x1,y1,x2,y2,x3,y3,x4,y4);
AB:=sqrt(sqr(x1-x2)+sqr(y1-y2));
BC:=sqrt(sqr(x2-x3)+sqr(y2-y3));
p:=2*(ab+bc);
s:=ab*bc;
write('p=',p,' s=',s);
end.
var X1,Y1,x2,y2,x3,y3,x4,y4, P,S,l1,l2:real;
begin
write('Введите координаты вершин треугольника ( A, B, C, D): '); read(X1,Y1,x2,y2,x3,y3,x4,y4);
l1 := Sqrt(sqr(x2 - x1) + Sqr(y2-y1));
l2 := Sqrt(sqr(x3 - x2) + Sqr(y3-y2));
S := l1 * l2;
P := 2 * (l1+l2);
write(S:3:2,' ',P:3:2);
end.
Если есть вопросы задавайте.