Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
kcenigolovaxa
30.06.2022 01:28 •
Информатика
Одномерный массив из n элементов. найти сумму элементов массива с четными номерами.
Ответ:
Lizok2509
26.08.2020 07:21
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln('Sчет=',a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
n= 15
10 -12 -5 65 -39 -76 -38 -68 69 87 94 11 -61 -2 -13
Sчет=5
0,0
(0 оценок)
Ответ:
nikitasolyny
26.08.2020 07:21
Var
a: array[1..1000] of integer;
i,s,N: integer;
begin
s:=0;
write('Введите N: ');
readln(N);
for i:= 1 to N do begin
readln(a[i]);
if i mod 2 = 0 then s:=s+a[i];
end;
writeln('Сумма элементов с четными номерами: ',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dwgerashenko
20.08.2020 11:34
Найти наименьший номер элемента последовательности, для которого выполняется условие (1). вывести на экран этот номер и все элементы аi, где i= 1,2,3 в excel и vba....
fernandus
15.11.2021 00:32
Название инструмента редактирования...
Misha91111
30.03.2020 15:06
Определите результат программы. 1 str= Молодец! 2 print(str[0;3])...
Yurgent
19.04.2023 11:03
(pascal abc)вывести на экран тремя используя операторы цикла for, while, repeat) кубы всех целых чисел из диапазона от a до b (a =b) в обратном порядке...
anhelinaivancha
19.04.2023 11:03
Напишите на python программу, которая складывает два числа, которые написаны в одной строке. и на каком языке нужно писать программы для олимпиад?...
max20170102
19.04.2023 11:03
Нарисовать граф по матрице смежности. 0,1,1,1,1,0,1,1,0,0 1,0,1,1,0,1,1,0,1,0 1,1,0,0,1,1,0,1,1,0 1,1,0,0,1,1,1,0,0,1 1,0,1,1,0,1,0,1,0,1 0,1,1,1,1,0,0,0,1,1 1,1,0,1,0,0,0,1,1,1...
Печенька1701
19.04.2023 11:03
Написать программу на паскале вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16.....
olga180982
23.12.2021 09:31
Написать программу на питоне. даны два целых числа a и b (при этом a≤b). выведите все числа от a до b включительно. входные данные вводятся два целых числа. выходные данные...
anya377
09.09.2020 07:56
Даны величины a и b. найти их сумму, произведение, среднее арифметическое и среднее . составить блок схему...
Арина20071278383
04.01.2022 22:43
Вшколе 3 этажа: на первом этаже y кабинетов на 2 и з этаажах по z кабинетов. определить количество кабинетов в школе. y=10 z=14 информатика...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln('Sчет=',a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
n= 15
10 -12 -5 65 -39 -76 -38 -68 69 87 94 11 -61 -2 -13
Sчет=5
a: array[1..1000] of integer;
i,s,N: integer;
begin
s:=0;
write('Введите N: ');
readln(N);
for i:= 1 to N do begin
readln(a[i]);
if i mod 2 = 0 then s:=s+a[i];
end;
writeln('Сумма элементов с четными номерами: ',s);
end.