Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Печенька1701
19.04.2023 11:03 •
Информатика
Написать программу на паскале вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16..
Ответ:
riaskor
31.07.2020 01:27
Данная последовательность -- последовательность центральных многоугольных чисел. Вычисляется по формуле a(n) = n*(n+1)/2 + 1. Или a(1) = 1, a(n+1) = a(n) + n.
Var
a, i: integer;
Begin
a := 1;
for i := 1 to 10 do
begin
writeln('base=', a, 'square=', a*a, ' cube=', a*a*a);
inc(a, i);
end
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
nastuxxxxa13
22.01.2023 06:39
Пример 4. алгоритм, позволяющий из полного сосуда ёмкостью 12 л отлить половину, пользуясь двумя пустыми ёмкостью 8 и 5 л.алг переливанияначнаполнить сосуд ёмкостью 8 л из сосуда ёмкостью...
Qqertyi
03.02.2022 02:24
Вычислите объем черного белого изображения в байтах...
МорскойКот
04.06.2021 08:10
Информатика объясните процесс обработки грома? по информатике...
Abigael
24.01.2022 12:59
Ақпаратты өлшеудің қанша түрі бар және қандай...
дада211
13.12.2020 12:26
Даны буквы, с них нужно составить слова. Буквы:А, Б, И, Д, У, С, К. Заранее огромное ...
abra123
17.10.2020 13:57
Невелика розповідь: як я використовую єлектронну пошту в житті...
muravyov1910
04.07.2020 09:34
Ввести 4 числа и найти из них минимальное, максимальное и сумму(паскаль) ! 25б за лучший ответ...
reginakajbeleva
15.08.2020 06:10
Составить блок схему.вычислить координаты вектора w= cy = , где c — скалярное произведение векторов x и y....
marina0708
26.07.2022 19:12
My first is an able modal verb my second is an auxiliary verb...
musinasim
26.07.2022 19:12
Сочинение на школа моей мечты с переводом взарание...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Var
a, i: integer;
Begin
a := 1;
for i := 1 to 10 do
begin
writeln('base=', a, 'square=', a*a, ' cube=', a*a*a);
inc(a, i);
end
End.