В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tonibaskakov
Tonibaskakov
02.05.2023 07:34 •  Информатика

Написать программу с массивом случайных 5 чисел от -50 до 50, если больше нуля - то сложить их, если меньше нуля - вычесть. (сумма и разность)

Ответ:
rogalikolenka
rogalikolenka
05.10.2020 05:32
Скорее всего так:
const n=5; 
var a:array[1..n] of integer;
i,s,r:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(101)-50;
 write(a[i]:4);
 end;
writeln;
s:=0; r:=0;
for i:=1 to n do
 if a[i]>0 then s:=s+a[i] else r:=r-a[i];
writeln('s = ',s,' r = ',r);
end.

Пример:
Массив A:
29 32 -48 -42 11
s = 72 r = 90
0,0(0 оценок)
Ответ:
NikaI004
NikaI004
05.10.2020 05:32
#include <iostream>
#include <stdlib.h>
#include <ctime>

using namespace std;

int main() {
    int a[5], p = 0, n = 0;
    srand ( time(NULL) ); 
    for (int i = 0 ; i < 5 ; i++) {
        a[i]=rand()%100-50;
        cout << a[i] << ' ';
        if(a[i] > 0) p+=a[i];
        else n-=a[i];
    }
    cout << endl << p << ' ' << n << endl; 
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?